Understanding of Sitecore Installation using SIF – Pre-requisites

Dear Sitecore Enthusiasts,

With the latest change in Sitecore Installation brought in by Sitecore, using Sitecore Install Framework (SIF), we as developers need to get some things in place so that the SIF install can continue.

We call these things to be set in place prior to the main installation as Pre-Requisites.

So lets get started with them so that we can proceed with installing Sitecore 9.

  • First and Foremost, Sitecore 9 can be installed only on Windows 8.1 or Windows 10. So in case you are still on Windows 8 or Windows 7 for that matter, its time for an operating system upgrade.
  • Next, The Web Server on which Sitecore 9 can be installed, is IIS 8.5 or IIS 10. Again, if you have Windows 8.1 or above this shouldn’t be a problem.
  • With Sitecore 9, the .NET Framework version we need have is .Net Framework 4.6.2 or later. Check this link
  • Sitecore 9 requires Microsoft SQL Server 2016 SP1. Why? Because with Sitecore 9 – Sitecore doesn’t have the dependency on Mongo for the Experience Databases as they can now be installed on SQL Server and for that reason, we need SQL Server 2016 SP1.
  • Next, I am sure we will need Visual Studio installed on our Dev machines. We need to make sure that the Visual Studio installed is 2015 or higher. [Update August 7th 2018] Also, One of my colleague faced a problem after even having Visual Studio 2017 installed on my machine. I was unable to see .Net Framework 4.6.2 in my Visual Studio 2017 in the dropdown to select the Framework version for my Web project. In case you face the same, make sure to install the .NET Framework 4.6.2 Developer Pack – For more details, check this link.
  • Now, we go and open Windows PowerShell (as an administrator and check the version. The pre-requisite for this is the version should be PowerShell 5.1 or higher. For this, after we open the PowerShell we fire a PowerShell Command $PSVersionTable.PSVersion. As an information, the PowerShell main version need to be 5.1 – the lower version can be anything. In case your PowerShell version is lower than 5.1 make sure you go and run Windows Updates. [Update July 5 2018] One of my colleague – Damini – faced an issue recently, and the solution regarding Windows Update works – check here
  • Next, Update the Web Platform Installer (Web PI) to 5.0 In case your version is lower than 5.0, go to the following link and update it for yourself: https://www.microsoft.com/web/downloads/platform.aspx
  • Now, open the Web Platform installer and search for WebAdministration Module. Basically, this gets installed when we install IIS, so we should be good. But always good to check.
  • Next, Search for Web Deploy 3.6 for Hosting Servers in Web Platform Installer, and install it. Sometimes, even after installation, the Web Platform installer says that the Web Deploy 3.6 for Hosting Servers is not installed and the “Install” button is enabled. In this case, go and clear the Web Platform Installer cache and if required, restart your machine.
  • Now, install URL Rewrite 2.1 using the same Web Platform Installer.
  • Next, install Microsoft SQL Server Data-Tier Application Framework (DacFx) version 2016 using the following link: https://www.microsoft.com/en-us/download/details.aspx?id=53013
  • Now, Sitecore 9 requires Solr 6.6.2 and that too on SSL – check the Solr compatibility Table – so lets install Solr 6.6.2 as a Windows Service first and next, lets get it on SSL either by following the Apache link to Enable SSL or using Kamsar’s link to Quickly add SSL to Solr.
  • Last but not the least, Enable Contained Database Authentication by first connecting to the SQL Server 2016 SP1 instance in your Management studio, right click on the SQL Instance and select New Query and then Execute the following Query:

sp_configure ‘contained database authentication’, 1;

GO

RECONFIGURE;

GO

If it was executed successfully, we should see the message “Configuration option ‘contained database authentication’ changed from 0 to 1”

References:

Happy Sitecoring! 🙂

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.